cPanel yum update gives Error: Package: perl-Git

If you tried to update cPanel recently and received this error:

Error: Package: perl-Git-1.7.1-8.el6.noarch (@base)
           Requires: git = 1.7.1-8.el6
           Removing: git-1.7.1-8.el6.x86_64 (@base)
               git = 1.7.1-8.el6
           Updated By: git-1.7.1-9.el6_9.x86_64 (updates)
               git = 1.7.1-9.el6_9
           Available: git2u-2.14.1-1.ius.el6.x86_64 (ius)
               git = 2.14.1-1.ius.el6
Error: Package: git-1.7.1-9.el6_9.x86_64 (updates)
           Requires: perl-Git = 1.7.1-9.el6_9
           Installed: perl-Git-1.7.1-8.el6.noarch (@base)
               perl-Git = 1.7.1-8.el6
           Available: git2u-perl-Git-2.14.1-1.ius.el6.noarch (ius)
               perl-Git = 2.14.1-1.ius.el6

The solution is to manually tell yum to update git while skipping the section [main] in yum.conf excludes, with this command:

yum install git --skip-broken

It should then be trivial to run yum update.


Comments