Ensure PEAR on cPanel is up-to-date

On one of my cpanel boxes, I kept getting Deprecated warnings from PHP stemming from PEAR Config.php, Register.php and HTTP_Upload.php. When I logged into the cpanel control panel, it shoed that PEAR was up-to-date. A quick look at the server showed my I have two PEAR installs. One at /usr/local/lib/phpand one /usr/lib/php. The solution is easy: /usr/local/bin/pear -V /usr/bin/pear -V /usr/local/bin/pear upgrade PEAR /usr/bin/pear upgrade PEAR

{deprecated} CodeIgniter Hints: Extending Models

If you are new to CodeIgniter and are using CI 2.x, then you might run into this little issue. If you want to extend a model, which you will undoubtedly need at some point, you might get confused by instructions that say to do it this way:
class Users extends Model

You won’t get much love doing in trying to extend model in Code Igniter 2.0. Most controllers in CodeIgniter now use the prefix CI_ (that second character is an uppercase ‘i’).

This is the correct way to extend a model:
class Users extends CI_Model
and place the file into application/models:
application/models/Users.php

Page 1 of 2 pages  1 2 >